Telephone / Voice platform Incoming calls
Incident Report for Juice Broadband
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 12:03 GMT
Monitoring
The issue has been resolved, and traffic is flowing normally. If you are experiencing any issues please get in touch.
Posted Mar 15, 2024 - 09:50 GMT
Identified
We are aware that some customers are experiencing issues with incoming calls, this is under investigation and we apologise if you are affected.
Posted Mar 15, 2024 - 08:30 GMT
This incident affected: General.