DC02 to DC04 Link Down

Incident Report for Juice Broadband

Resolved

This incident has been resolved.
Posted May 23, 2026 - 09:07 BST

Update

The link has been stable for 30 minutes and has been re-enabled. We will continue to monitor closely.
Posted May 23, 2026 - 06:03 BST

Monitoring

The fibre is back online, we are monitoring it closely before returning it to service.
Posted May 23, 2026 - 05:50 BST

Investigating

We have detected an issue with a link between DC02 and DC04 which is out of service, reducing our redundancy. The fault has been raised with the fibre provider. Traffic has rerouted via our other routes and except for unprotected services using this route service is unaffected.
Posted May 23, 2026 - 04:42 BST
This incident affected: Core IP Network.