Fibre cut between Bournemouth and London

Incident Report for Juice Broadband

Resolved

The service has been stable for a number of hours, and so we are closing this incident. Apologies again if you were affected.
Posted Apr 07, 2026 - 15:11 BST

Identified

Service is recovering and we are monitoring. Apologies if you were affected by this.
Posted Apr 07, 2026 - 11:33 BST

Investigating

We have a fibre issue between Bournemouth and London which is causing degraded performance. This is being worked on updates to follow.
Posted Apr 07, 2026 - 11:25 BST
This incident affected: Core IP Network.