Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 22, 2024 - 00:00 GMT
Scheduled
CityFibre will be updating network infrastructure during this window. Select CityFibre Bournemouth connected customers impacted only.
CityFibre - "This is service affecting work; we expect services to remain available for the duration of the maintenance window except for a 5–10-minute window as upgraded cards are rebooted."
Posted Nov 06, 2024 - 10:13 GMT
This scheduled maintenance affected: FTTH & FTTP Business.