Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 19, 2025 - 22:00 GMT
Scheduled
Following the incident overnight with one of our backhaul connections, the fibre provider has advised they will be disconnecting the service to carry out repairs. This will cause connections to drop and reconnect a few times during the works, as traffic reroutes to another link. Apologies if you are affected, this limited disruption is required to carry out a permanent fix to avoid a further major service failure.
Posted Dec 19, 2025 - 16:06 GMT
This scheduled maintenance affected: xDSL Broadband (ADSL, FTTP, EoFTTC, SoGEA).