Pottery estate FWA issue

Incident Report for Juice Broadband

Resolved

The faulty hardware has been replaced and service restored
Apologies if you were affected.
Posted Sep 12, 2026 - 17:04 BST

Update

Replacement parts have arrived on site and will be fitted shortly.
Posted Sep 12, 2026 - 16:07 BST

Update

engineer has been despatched
Posted Sep 12, 2026 - 08:41 BST

Identified

We are aware of an outage affecting the Pottery Industrial Estate FWA repeater on Ringwood Road, Poole. This is under investigation.
Posted Sep 12, 2026 - 07:18 BST
This incident affected: Microwave Broadband.