xDSL connections dropping (FTTC, SoGEA, ADSL, and FTTP)
Incident Report for Juice Broadband
Resolved
The supplier has confirmed the fault resolved.

Apologies if you were affected.
Posted Jan 21, 2024 - 10:18 GMT
Monitoring
We have seen a period of stability over the last 30 mins. If your connection has not restored, please turn off then turn on your router.

Please do not press the reset button on your router, simply power off by unplugging wait for 10 seconds then power back on.
Posted Jan 20, 2024 - 23:12 GMT
Update
We are continuing to work on a fix for this issue.
Posted Jan 20, 2024 - 21:57 GMT
Identified
Our transit provider for some xDSL tails has identified a network incident affecting a large number of xDSL (FTTC, ADSL, and FTTP) broadband customers. Our suppliers engineers are investigating the cause of the issue.

Please do not press the reset button on your router, simply power off by unplugging wait for 10 seconds then power back on.

We apologise for any inconvenience this may cause.

Further updates to follow.
Posted Jan 20, 2024 - 21:56 GMT
This incident affected: xDSL Broadband (ADSL, FTTC, EoFTTC, GEA).