We have been advised that power should be restored today once the affected device has been worked on. We will advise once we see power return. In the meantime the secondary link continues to carry traffic as normal.
Posted Sep 18, 2025 - 09:58 BST
Update
Battery backup has now been exhausted on the primary link, and traffic has migrated per design to the secondary backup link. Customers will see slower than usual performance during peak periods. Apologies if you are affected. We are working with the landlord to restore power ASAP.
Posted Sep 13, 2025 - 16:03 BST
Update
A fix has been implemented for the issues with the backup link. The power issue is ongoing. We will continue to monitor and pursue getting power restored ASAP.
Posted Sep 12, 2025 - 18:07 BST
Identified
During an electrical storm this morning power was lost at 9am to the primary link equipment into Kimmeridge. This site is running on battery backup and has approx 12-18 hours remaining. The landlord has today advised the power issue has been fixed and so we will despatch an engineer tomorrow (Friday) to investigate why we still see loss of power. In addition at 8.30am today the secondary link into the area was damaged by wind gust, and we are seeking to get this repaired ASAP, by tomorrow (Friday) PM weather permitting. If power cannot be restored and the backup link cannot be repaired then there is a risk of a loss of service for Kimmeridge, Church Knowle and surrounding areas. Further updates will be posted here.