Pottery degraded service

Incident Report for Juice Broadband

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 17:27 GMT

Update

We are continuing to monitor for any further issues.
Posted Jan 23, 2026 - 13:55 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 23, 2026 - 13:55 GMT

Update

engineers are on site working on the fault.
Posted Jan 23, 2026 - 12:52 GMT

Identified

We are aware of an issue at at Pottery repeater causing degraded service in the immediate area. This is under investigation. Apologies if you are affected.
Posted Jan 23, 2026 - 11:53 GMT
This incident affected: Microwave Broadband.