The fibre issue has been resolved restoring service.
Posted Dec 19, 2025 - 09:43 GMT
Monitoring
We have seen a couple of hours of stable connectivity and continue to monitor.
Posted Dec 18, 2025 - 22:04 GMT
Investigating
Due to a fibre cut in London some customer sessions are not arriving, meaning intermittent or no service. This is being investigated urgently, and the cut fibre is also under repair. We apologise if you are impacted.
Posted Dec 18, 2025 - 19:41 GMT
This incident affected: xDSL Broadband (ADSL, FTTP, EoFTTC, SoGEA).