Purbecks Power problem
Incident Report for Juice Broadband
Resolved
All services are now restored, back on mains power and working normally.
Posted Jan 26, 2024 - 13:52 GMT
Monitoring
We are seeing power restored to Kimmeridge main, and customers reconnecting. Church Knowle area remains offline and we are investigating if power has been restored.
Posted Jan 26, 2024 - 12:27 GMT
Update
SSE have updated us to advise they plan to have power restored by 12pm.
The main Kimmeridge repeater is running on battery backup. Church Knoll Repeater has already exhausted it's battery backup and shutdown.
Posted Jan 26, 2024 - 09:31 GMT
Identified
There is currently a widespread power failure in Kimmeridge and surrounding areas. SSE are aware of the problem and working to restore power. In the meantime our service in Kimmeridge and surrounding areas is operational on backup power but should be considered at risk.
Posted Jan 26, 2024 - 07:35 GMT
This incident affected: Microwave Broadband.