Performance issues Poole surrounding areas

Incident Report for Juice Broadband

Resolved

This incident has been resolved.
Posted Dec 09, 2025 - 12:22 GMT

Monitoring

A fault on a switch in DC07 has been resolved and service has returned to normal. We will be monitoring for further issues, but consider this a permanent fix. Apologies if you were affected.
Posted Dec 09, 2025 - 10:39 GMT

Update

The fault has been isolated to our DC07 site and an engineer has been despatched to investigate.
Posted Dec 09, 2025 - 10:12 GMT

Update

Investigation continues apologies if you are affected, we are working on the problem as a priority.
Posted Dec 09, 2025 - 10:00 GMT

Identified

We are aware of performance issues in Poole and surrounding areas, this is under investigation, updates to follow.
Posted Dec 09, 2025 - 09:07 GMT
This incident affected: Microwave Broadband and Core IP Network.