Branksome Business Park, including Coy Pond and surrounding areas - issue

Incident Report for Juice Broadband

Resolved

Service has been stable since 5pm when the new equipment was confirmed online and all customers reconnected.
Posted Sep 04, 2026 - 19:23 BST

Update

We are still seeing issues with this site and working on a fix. Apologies if you are affected.
Posted Sep 04, 2026 - 15:49 BST

Update

Parts have been replaced and service restored. We are monitoring.
Posted Sep 04, 2026 - 14:43 BST

Identified

Unfortunately the issue has re-occurred, an engineer is being despatched to replace the affected parts.
Posted Sep 04, 2026 - 13:51 BST

Monitoring

A faulty switch has been identified, service is now restored and we are monitoring. Apologies if you were affected this outage.
Posted Sep 04, 2026 - 13:06 BST

Update

engineer despatched to site
Posted Sep 04, 2026 - 12:39 BST

Investigating

We are aware of an issue with service affecting Branksome Business Park, including Coy Pond and surrounding areas.
This is under investigation, updates to follow.
Posted Sep 04, 2026 - 12:33 BST
This incident affected: Microwave Broadband.