Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 13, 2025 - 22:00 GMT
Scheduled
We will be upgrading the firmware of broadband LNS edge routers which handle ADSL, FTTP, and SoGEA connections during this maintenance window. In addition we will enabling more capacity.
Customers will see brief (5-15mins) disconnections during the planned works window, hence carrying the work out during this maintenance window to minimise disruption and to ensure network stability.
We apologise if you are impacted by these works. If, once the work has completed you have no internet access, please power off and then power on your router. Please do not press the reset button.
Posted Nov 10, 2025 - 15:34 GMT
This scheduled maintenance affected: xDSL Broadband (ADSL, FTTP, EoFTTC, SoGEA).